05/27/17 01:10 AM  

RingCentral to Stop Support for Old Browsers

« Go Back

Article

 
SummaryWhat browser should I use to access my RingCentral Online account?
Details

In order to protect our customer's privacy, RingCentral will be rolling out a change that affects users of older browsers that are not compliant with the current industry standards. Users of non-compliant browsers will be prevented from getting to their RingCentral Online account, and will be redirected to a page that will inform them that their browser is unsupported.  

Click here for RingCentral's List of Suported Browsers.

See the table below for the list of affected browsers: (RingCentral Online account)
 
Browser TypeAffected VersionsSupported Versions after
Roll-out
Google Chromeversion 30 and lowerversion 41 or higher
Microsoft Internet Explorerversion 10 and lowerversion 11.x, Microsoft Edge
Mozilla Firefoxversion 27 and lowerversion 37 or higher
Safariversion 7 and lowerversion 7.x or higher
 

Summary of Supported Browsers for RingCentral Integration Apps

IntegrationSupported Browser
RingCentral for Google for Work• Google Chrome version 39 or higher
RingCentral for Office365• Google Chrome version 39 or higher
RingCentral for Salesforce• Google Chrome version 30 or higher
• Mozilla Firefox version 25 or higher
• Safari version 6.0.5 of higher
• Microsoft Internet Explorer 11 or higher
RingCentral for Zendesk• Google Chrome version 30 or higher
• Mozilla Firefox version 25 or higher
• Safari version 6.0.5 of higher
​• Microsoft Internet Explorer 11 or higher
RingCentral for Desk• Google Chrome version 30 or higher
• Mozilla Firefox version 25 or higher
• Safari version 6.0.5 of higher
​• Microsoft Internet Explorer 11 or higher
RingCentral for Oracle• Google Chrome version 30 or higher
• Mozilla Firefox version 25 or higher
• Safari version 6.0.5 of higher
​• Microsoft Internet Explorer 11 or higher
 

Android Users

Customers on Android versions older than 4.4 will be impacted.
 
• SSO, Forgot Password, and Reports will fail on Android OS 4.3 and lower.

• RingCentral Mobile Web (
Express Setup, Extension Settings, Phone System, Billing) will work as long as the user's device is using Chrome 30 and higher.
 

Frequently Asked Questions

Q: What is the reason behind this change?
A: Due to security vulnerabilities, RingCentral will no longer support older browser versions.

Q: What do I need to do?
A: Please make sure that you are using the latest browser version. Visit the RingCentral Community page to know how to upgrade your browser: https://community.ringcentral.com/ringcentral/topics/ringcentral-supported-web-browsers

 
Ranking
Was this information helpful?
Yes
No
Somewhat

Tell us why and what can we do to improve this information