12/08/17 19:30 PM  

RingCentral Mobile App: Unable to Receive Notification / Incoming Call Samsung Devices

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SummaryWhy am I unable to receive notifications or incoming calls with the RingCentral App on my Samsung device?
Details

Description

Some Samsung phone users may notice that RingCentral Mobile App cannot receive notifications or incoming call after the App is turned OFF or put to background for a while.


Environment affected

• Samsung phones OS version 7 or later
• RingCentral Mobile App is not added to  Unmonitored app list


Cause

The RingCentral Mobile App needs to keep a background service running, in order to make sure user can receive incoming calls and notification. However, if RingCentral Mobile App is NOT in the Unmonitored apps list, the background service running will be blocked.


Workaround

i. Reboot the Samsung phone.
ii.  Add the RingCentral Mobile App to the Unmonitored app list from system settings.

Step 1:

On the Samsung mobile device, go to Settings and tap Device maintenance.

samsung settings - device maintenance


Step 2:

Tap Battery.

samsung settings - device maintenance - battery


Step 3:

Tap Unmonitored apps.

samsung settings - device maintenance - battery - unmonitored apps


Step 4:

Tap Add apps and add RingCentral to the Unmonitored apps list.

samsung settings - device maintenance - battery - unmonitored apps - add


IMPORTANT

Inform user to add the RingCentral Mobile App to the Unmonitored apps list manually by adding some tips when they are using the app.
 

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